VDMX Beta 8.7.2.7 now ready for testing!

#1

Hey Everyone!

We have a new update for you to try out!

This build is a stepping stone on our way to an Apple Silicon native update - we are still waiting on universal binaries for a few 3rd party libraries, as soon as we get our hands on those we’ll be able to put that together.

As we’ve only a significant number of changes behind the scenes to update the codebase and various frameworks (including Vuo and NDI), we have tried to make minimal changes to the rest of the app, so it will be easier to find and fix any regressions.

If you run into any problems, please use the “Report Bug” option in the Help menu.

Download here:
https://vidvox.net/download/VDMX5_b8.7.2.7.dmg

Beyond this we are also hard at work on another major backend change to make all the rendering run in Metal which we are hoping to roll out later this year. Thanks for your patience as we get these architectural changes out of the way!

14 Likes

Vuo x VDMX: Update to latest framework
#2

Appreciate the continued NDI love, does this ready VDMX for NDI HX and ver5?

0 Likes

#3

@SFinSF NDI V5 SDK is not available yet.

0 Likes

#4

What does the Metal implementation mean for ISF?

-m

1 Like

#5

Thank you for this update! It’s a great feeling to have these two working nicely together. :zap: Have spent a few hours with Vuo 2.3.1 on MacOS 10.13.6 and so far so good. So nice to be able to use the latest Vuo nodes, seems faster and more stable and the MIDI mapping issue is fixed.

Does this include the update where VDMX at runtime uses the Vuo framework that is in the Vuo app itself, rather than a version that is bundled inside VMDX, mitigating the need for VDMX to release an update each time Vuo updates the framework?

Thanks for the work on this!

1 Like

#6

From David:

We are pretty sure that all existing GLSL shaders are going to work fine under Metal, we can adapt them on the fly to Metal shaders.

1 Like

#7

From David:

The VIDVOX team is looking into this Vuo framework.

1 Like

#8

I’ve made some reports thru the app… thru my trials i have gathered some other logs and snapshots that may be useful… where should I submit those or should I wait to hear a reply about my bug report?

thanks

Kerry

0 Likes

#9

I’ve noticed when I clear the Vuo Cache on 8727 that Little Snitch gives me a warning about Code Signing…

I allow it and everything works fine.

PS Running Vuo 2.3.2.11 on Mac 10.13.6

See attached screenshot:

0 Likes

#10

I should also add that the latest Beta of VDMX is 10.13+. 10.12 and older runs into weird issues.

1 Like

#11

Downloaded and tested the beta, found immediate issues, present in multiple projects. Before reporting, wanted to go back to previous non-beta to verify projects were okay there. Reloading them in 8.7.2.4 confirms them working fine, so problem is obviously something in the new beta, but upon launching that old “non-beta” 8.7.2.4 got this license request, attached.

How can we swap between the new beta and the old non-beta beta without having to relicense the app every time? Did I just use up a license seat by trying to help…? I’d love to help and report the problems i found, but i can’t risk my license for this… ;)

0 Likes

#12

I am experience the same issues.
Only with my larger projects. Some of my smaller ones that include New Vuo 2.3 compositions work fine.

Before I installed 8727 I renamed 8724 by putting 8724 at the end and moved it to a Visuals folder in my applications folder. Then I could have both apps.

Once you’ve liscenced them you should be able to open individually so hour having to reauthorize.

0 Likes

#13

Here is some info from the VDMX Logs from both versions… App Load only no Project Opening. There is a few differences on when the OSCQuery Server starts and the VVLighting manager quits.

Also in 8727 there are two variables that it can’t access.

From VDMX 8724 Launch:

06-26 38.947 +[VVStatChecker populateDefaultRenderingPrefs]
06-26 39.060 GPU vendor array is (
“NVIDIA Corporation”
)
06-26 39.060 renderer name is NVIDIA GeForce 9400M OpenGL Engine
06-26 39.263 -[VVLightingManager init]
06-26 40.833 err: MDItem created but no content type detected at path - /Volumes/Audio Projects
06-26 41.937 -[VVOSCQueryServer start]
06-26 41.940 web server running on port 2345, try connecting to http://localhost:2345
06-26 42.125 VBL is 1
06-26 42.125 display output mode is 0
06-26 42.125 displayDrivenRenderer is 1
06-26 42.125 doubleBufferedOutputs is 1
06-26 42.126 QCAA is 0
06-26 42.126 QC AA is 0
06-26 42.126 safeQCRender is 1
06-26 42.127 skipCanvasRender is 0
06-26 42.127 applyFXToDuplicateFrames is 0
06-26 42.127 CIQCWarningType is 1
06-26 42.141 -[VVLightingManager stop]

From VDMX 8727

06-26 55.149 +[VVStatChecker populateDefaultRenderingPrefs]
06-26 55.208 GPU vendor array is (
“NVIDIA Corporation”
)
06-26 55.208 renderer name is NVIDIA GeForce 9400M OpenGL Engine
06-26 55.409 -[VVLightingManager init]
06-26 56.965 err: MDItem created but no content type detected at path - /Volumes/Audio Projects
06-26 58.228 QCAA is 0
06-26 58.228 QC AA is 0
06-26 58.228 safeQCRender is 1
06-26 58.228 skipCanvasRender is 0
06-26 58.228 applyFXToDuplicateFrames is 0
06-26 58.228 CIQCWarningType is 1
06-26 58.228 VBL is 1
06-26 58.228 display output mode is 0
06-26 58.228 displayDrivenRenderer is 1
06-26 58.228 doubleBufferedOutputs is 1
06-26 58.250 -[VVOSCQueryServer start]
06-26 58.253 web server running on port 2345, try connecting to http://localhost:2345
06-26 58.277 -[VVLightingManager stop]
06-26 58.513 err: -[ObjectHolder initWithZWRObject:] - BAIL
06-26 58.513 err: -[ObjectHolder initWithZWRObject:] - BAIL

0 Likes

#14

So having trouble loading my old project into 8727 I’ve created a Vuo Plugin that you can place at various points between your plugins.
You can enter the following text

  • PlugIn Position Number
  • What Plug In Does this log come after
  • What Plug In Does this log come before
    When it loads it will write to the VDMX log file that info.

Technomorph Debug Log.vuo.zip (1.9 KB)

Unzip and install to your VDMX PlugIns folder at
~/Library/Application Support/VDMX/plugins

First Open Your Project in 8724 and save As so you don’t wreck anything.

Add the plugIn Named Technomorph Debug Log in your Plugins Tab

Now to Place it where you want it… You Need to rename appropriately.
I want it before the first Audio PlugIn.
So if you use the 1st Character of the Plugin you want before, then add a 1 to it. It should place it where you want it. In this case I named the first one A1 Debug Log.

03%20Debug%20Log%20Info

Move you new plug in tab where you can see it.
Enter you info. In this case:

  • PlugIn Position 1
  • Comes After: Program INIT
  • Comes Before: Audio PlugIn And Audio Control Surface Plugins

Now we need another copy… Don’t use Duplicate it doesn’t work.
Use the gear and COPY SELECTED PLUGIN TO CLIPBOARD.

Now Use Paste to New PlugIn… This should put it in the same Tab as the other.

For some reason it doesn’t know what to call the plugIn and it changes the category to XXX. It will be at the very top with an invisible name and the category XXX.

Now you can rename it and add info.

Once done all your placements…

---------------------------------------------======================================

  • Save a copy of this new project.

  • Change VDMX Preferences to not Trigger 1st Preset on project launch
    (this will allow VDMX to compile any Vuo resources it needs to and it will also load all of the files)

  • Quit VDMX 8724

  • Open the Console App and Go to ~/Library/Logs/VDMX

  • reopen 8724

  • Go to the Console and select the very last file in the logs

  • Watch it populate as it loads the App

  • then open the project you just made with your new plugIns.

  • again goto Console and Watch, don’t trigger for a bit, til you see all activity die down

  • once ready go to your presets menu and trigger your first preset

  • again goto Console and Watch, it should show the loading action
    (I’ll show examples in next post)

  • once it finished launching, save it as a different copy

  • quit

Then open 8727 and follow the above except open you copy.

More in next post

1 Like

VDMX Debugging Plug In (How to find out 8727 Crashes)
#15

You can email support@vidvox.net and get your license reset. It’s pretty low risk (imho). But definitely share with them what you’ve got. Using “Report Bug.” I only had issues opening projects on a 10.12.6 computer, but they opened perfectly on a 10.13 machine. It’s definitely 10.13+ at this point. I know some legacy plugins no longer work, but if you submit the projects that are causing the issues, then you can help this version of VDMX become the stable one faster. Thanks!

0 Likes

#16

I’ve reported the issues. The report formular says “every report gets a personal response”, which I haven’t, and I have a notion I’m not the only one?

I have not gotten any reply from Vidvox on any matter in any channel for over 14 months, this includes several reproducible bug reports, a massive oceans of crashes, and also license purchases. It is quite unprofessional to never reply but I understand the pandemic affects us all in different ways, Vidvox is a small team and could have personal challenges too, I am grateful that the company and app is surviving, and working on future proofing the app, which is an important tool for me. I’d like to support them both with beta testing and purchasing license. I would not mind a subscription model. But I am not much inspired to help improve the software when reports feels like throwing them into dev/null for over a year?

It looks like you @ProjectileObjects have an open line of communication with the developers, I don’t know if you have an official role or position, but am anyway grateful for your work here and keeping us updated on betas and their progress. I was very close to go for another solution before you started updateing us. Can you please let them know that at least just acknowledge our existence and reports. I don’t need a pretty letter or thank you note, but just “the issue is noted”. A support tracking system would probably benefit everyone but I agree a modernized Apple silicon VDMX is most important, and that if the team needs to disappear for a while to make that happen, I’ll be patient.

1 Like

#17

@GMM

I understand your frustrations.

Sorry for not making this clear before.

I’ve been working with the VIDVOX team as a support member since January and check the forums daily. When something needs more attention, I’ve passed that information on to them. And when there’s a bug report filed, they see it directly. Whether or not you get a response back, that info is taken into account. If you send a message to support@vidvox.net I see it and if I’m unable to help then I pass it on to them.

If there is something specific that you’re having a problem with now, send me a private message me or email us and I’ll see what I can do.

-Cornelius

2 Likes

#18

Thanks, I’m glad they have good help, I appreciate your work (and I appreciate their work too). For now I’m okay and patient, glad to see work on the app, VDMX has been massively unstable for me over the last 12 months and I’ve reported it endlessly, I’ve given up and now built “VDMX crashed” into the performances. Am hopeful this new version will mature the app a bit, and as many others am waiting for updated Macbook Pros which I also hope will help with better load and thermal balancing, I do not always suspect VDMX itself is the problem.

it would probably make sense to take out the “Every report gets a personal follow up” and “Would you like a follow-up to this crash report” option from the bug and crash reports. ;)

1 Like

#19

III’ve been using VDMX for over 15yrs and from
My experience. Any of the crashes that happen are usually due to something in my project.

  • bad media (including quartz, isf sources)
  • bad / broken Revievers / Senders
  • bad / broken Plug-ins
    (Have a look a this post where I walk
    Thru finding out how to find trouble plugins)
    Plugin Debugging

-The VDMX logs can help possibly point to what’s happening.

  • the VDMX Menu Show Data Connections. An helpi

I’ve found that I’ve need to save my project as a copy in a “Debug Folder” somewhere.

  • have a look at the logs

  • if it seems like media issues start removing media or pages… save as don’t update preset and see happens.

  • or if it’s plugins start slowly removing them (or
    As show with my Debug Plugin Loggee, moving them)

I was having an issue with a project with 9 LFOs
That when the project loaded their time
Was not connecting to the clock plug in BPM.
It was showing Seconds not measures.
Also in the Data Connections menu. The Clock was showing Time and Bpm had connections
To it but showed ??? Beside them.

After trying a bunch of things (and looking at he Log, which was showing errors about none existent menus). I realized I had renamed my clock plugin to “S-Clock” and it was loading after my “LFO ***” plugins. As soon as I renamed my Clock plug in so that alphabetically it came before anything that needed it. It solved many problems.

1 Like

#20

I had multiple crashes on two machines which David thought could be related to audio routing. A typical session for me would be play audio from a Safari (web browser) stream and use Loopback (https://rogueamoeba.com/loopback/) to route the audio for analysis and movie recording.

I’ve not been able to replicate the crashes since and I was wondering if any other Loopback users have had issues?

Cheers,

Michael.

0 Likes