Vuo x VDMX: Update to latest framework

#7

Yes the integration with VDMX is key so I’m really hoping we’ll hear something soon!

1 Like

#8

Sigh :( have a stream tonight and a bunch of patches are exhibiting really strange behaviour when imported into VDMX - cropping strange and breaking all the other Vuo files as well. This is honestly really worrying - and I don’t understand why we’re not getting any response. So frustrated with the lack of communication, this is quite awful.

0 Likes

#9

Hi @Joelle I have the same problem as you with the MIDI Mapping.
It is crazy !!
The only solution I found was to choose the option “RUN VUO IN SEPARATE FILES” on Preferences MENU/VUO.
This way it keeps the MIDI mappings, but it is slower, specially starting/loading the files. Which is not very cool on a live performance where you want to change visuals fast.

0 Likes

#10

It’s so frustrating :frowning: Thanks for the tip to run separately in preferences but agree is not ideal solution. Have you tried emailing support? I didn’t get any response yet.

0 Likes

#11

Adding here for anyone interested that David has replied :smile: - they’ve been busy updating the codebase for Metal etc. My questions are in bold below with his responses as quotes.

Lastly, there are some new super cool nodes since the very recent latest update of 2.2 that are not allowing me to import the comps.

We’re putting together an intermediate update with some general minor fixes in early February, but I’ll talk to Ray about getting out a build with the new Vuo framework sooner than that since that is likely a lot easier to put together, and I think we need to update the NDI framework as well.

The one where VDMX doesn’t remember MIDI mapping

This definitely looked reproducible from the videos from the user, and it definitely looks like it is on our end of things! When I initially tested for it I wasn’t able to reproduce it on our end, but I’ll give it another try today and see if I have any better luck recreating it this time.

The other is when sub-compositions will be supported?

We can look into it for the update in February, but we honestly haven’t started to look into it yet. Is there something special we need to do on our end for this?

I’ve added this to the Vuo forum too, will follow up the sub-comps question with them.

4 Likes

#12

It’s a relief to know that they’re working on it! Thanks for the info.

2 Likes

#13

I have the same problem remembering OSC mappings. Its fine when its playing a single clip, when I have a OSC mapping or slider to change the clip no in the media bin for the layer, the OSC mapping for the Vuo published parameter is lost. Using Vuo 2.2.1.11486 and VDMX 5 b0.8.7.2.4

0 Likes

#14

Desperately waiting for this to be fixed in the new hopefully impending update.

1 Like

#15

Hey Guys,

Has anyone found an issue with the way thumbnails are generated with the latest version of VDMX and Vuo?

I’ve tried a few ways to change this and so far not found an easy way to change my thumb in VDMX. My comps in Vuo usually start with a template image where the opacity is turned down.

Even if I save the file with the value = 0 for the image layer, it still uses this image as the thumbnail in VDMX. I also tried changing the order of the layers so my real comp images/layers are first in the list. I have left to try another image of the thumb as layer 1 and change the opacity after loading in VDMX to 0. But wasn’t sure if there are any other handy tips please?

Cheers

0 Likes

#16

A month later almost and still nothing… my Vuo comps just randomly break in VDMX, this is so frustrating… am doing a stream this weekend and another one in a few weeks and this is making it impossible to rely on Vuo comps. Emailed David last week and no reply??? Concerning

0 Likes

#17

Never mind the MIDI mapping issue - the Vuo files themselves bug out randomly and break the entire VDMX file, basically have to restart computer to flush something and then sometimes works or reimport the comps but it’s totally random, did a stream not so long ago and the comps ran fine - now they are all broken.

0 Likes

#18

Hi Joelle,

I feel your pain, the behaviour now is really random, yesterday I worked fine and today I have odd results when certain elements just do not work anymore. No reply to my email either.

1 Like

#19

I can neither confirm nor deny, but there was/is an update in testing which addresses Vuo (and much more). Apparently, Apple made a lot of “quiet” changes in Big Sur which forced the update to go through another round of code changes to make it compatible for new and old OS’, and both Intel and M1 Macs.

I’d rather “wait” for a stable version of VDMX, than risk a crash during a live performance. (IMHO)

0 Likes

#20

David said they were hoping to release an update to beta testers end of last week / early this week (no promises though) Am hoping we will get it in the next few days. Am in a pretty ropey position myself with upcoming performances and pretty nervous if things don’t land soon.

3 Likes

#21

Yep, the UK Govt stage 4 date of June 21st is looming fast and that first weekend is when my bookings start. Would be good to have Vuo working, but in my case I can find a work around as I’m mainly pixel bashing for the fist bunch of events and not too reliant on Vuo.

2 Likes

#22

:sweat_smile::sweat::face_with_monocle:

0 Likes

#23

Feels like groundhog day :anguished: gonna have to start looking at alternate solutions with impending gigs… really sucks. (EDIT) will be some time still, heard back and it’s not ready… it is what it is so just need to be patient and hope

0 Likes

#24

For now I’ve rolled back to V1.2.8 as all my nodes are covered in this version and can’t wait any longer. Cleared my cache and created a new VDMX composition. I’ve left my project running on soak test for 4-5 hrs with no real issues for a number of times now, occasionally if I send conflicting OSC data when creating my data set by mistake and then it will loose the OSC mappings for Vuo parmeters but usually its fine once set. Or I’ve not been able to replicate what causes the values to be lost.

I’m controlling values within Vuo clips and sending OSC values from Vezer app which generates the OSC data.

I switch clips quickly in the media bin between 3 layers and as a result I’ve noticed that there’s a slight latency the first time the clip is played. As a work arround I have a 1 second delay before the sound track is played where I load the clip but turn down the opacity for the layer, which works fine. For other clips selected from the media bin I select these in advance with the opacity turned down.

My set relys on optimal performance and very low latency as I’m outputting via Syphon to MadMapper to control an LED lighting rig via Art-Net controllers.

Has anyone else seen this before and found another way to resolve this please, its like there a delay while the Vuo clips are loaded?

0 Likes

#25

Any news or chance we will get that update anytime soon? :pensive:

0 Likes

#26

News! VDMX Beta 8.7.2.7 now ready for testing!

2 Likes