VDMX crashes after loading presets many times

#1

Hey,

First I just wanna say im a massive fan of vdmx and have been using it as a key part of my workflow for both installation and vj work :slight_smile:

Im currently working on an installation that uses osc communication from openframeworks to trigger different presets I have made on vdmx. it works perfectly fine for a while but crashes after a certain amount of time (an hr or so), the presets are not being triggered rapidly (maybe every 20 seconds). different layers and blendmodes have 9 presets each. I also have the opacity of some layers being controlled by osc. After some testing I’ve found that it crashes after around 200+ preset triggers.

overall, the project runs fine and my computer does not seem to be under huge stress (vdmx is using maximum 50% CPU and there is minimal thermal throttling) and I’m using an external gpu. Im currently running Catalina on a 2018 MacBook 15inch.

Any advice would be greatly appreciated as I need this installation to run smoothly.

Thanks in advance!

0 Likes

#2

I get this also. I haven’t counted how many presets before crashes, as mine seem to be more random. Sometimes it never crashes during triggering, sometimes it will crash three times. I am using a 2019 MBP 16" i7 2.6ghz, with Catalina. I can run the presets without any crashes, although very glitchy, on my 2010 Mac Book Pro on High Sierra with any crashes ever, so am wondering if it is an OSX version glitch

0 Likes

#3

What version of VDMXBPM are
You using?

I would suggest having a look at the
Come Display plug in and
Monitor OSC messages

I was having VDMXBPM crash when sending OSC messages too quickly. IE moving and external slider from the testOSC app back and forth really quickly.

0 Likes

#4

Hi @maxjala,

Did you try sending a bug report into support@vidvox.net with your crash logs? You can use the “Help > Bug Report” option inside VDMX to send it directly. Also, which version of VDMX are you currently using?

Thanks,
-Cornelius

0 Likes

#6

hey @ProjectileObjects ,

yeah i did submit a bug report with my crash log. Im using version b0.8.7.2.4. I’m also sending a 0 value via osc to some opacity sliders every frame - could this be the problem perhaps?

cheers,
max

0 Likes

#7

Have just done this.

0 Likes

#8

Any change when you use the latest beta?

An update to this one is coming out soon that will address a few issues, but maybe it can get you back up and running.

The other thing I recommend is completely deleting and uninstalling the VDMX app and then reinstalling over top of it. Just installing over top of an existing installation might not clean up some of the older files you’re trying to get rid of.

Let me know if this helps.

1 Like

#9

Trying it now. Will run it a few times today and see what happens

0 Likes

#10

Yep, the update has stopped the crashes! Thank you!!

1 Like