VDMX Beta now ready for testing! (M1/Intel) OSX 10.15+

A new update for everyone 10.15+ (If you have an older OS you can try this version, but let us know if it doesn’t work for you).

If you are using 10.14 and older, you’ll want to use the legacy version fo VDMX b8.7.2.4
More details about VDMX versions in the wiki doc: https://docs.vidvox.net/vdmx_versions.html

b8.8.0.8 list of improvements:

  • Fixed issue with cue list to be able to select clips from bin
  • Timecode can now be adjusted to 00:00:00:00 (instead of :01)
  • Image max file size in preferences is no longer limited to 4196 pixels. The text field in the prefs will automatically ensure that the value entered by the user is less than or equal to the max texture size allowed by the user’s GPU.
  • Fixed a hang when detecting BlackMagic Inputs
  • Minor UI fixes.

Download: https://www.vidvox.net/download/VDMX5_b8.8.0.8.dmg


I’ve been banging my head against the table the the last 2 days trying to get a BMD extreme ISO and an Ultrastudio Recorder 3g to play nice with intermittent luck. Thank you for this, best timing ever!

1 Like

Any chance of fixing this slider issue? when you click on any other application when using VDMX like Finder, it appears on the VJ screen.

@bada I’m not sure what you’re saying. Could you capture a video of what you’re experiencing?


Uncheck: System Prefrences > Mission Control > Displays have separate Spaces

1 Like

Please have a look at this video, I know this will not happen if you turn off “Displays have separate spaces”, but I need to use this feature… This does not happen in Resolume.

That’s a strange one. I’m not experiencing. Do you have 'Keep windows on the main screen" or “lock windows” enabled?

How about your full screen options? What are those set to?

Finally, feel free to submit a bug report via the build in help menu so we have your system information.

Here’s my settings:

Displays have seprate Spaces: ON

It’s the same no matter which sizing mode you use.
Enabling “Keep windows on the main screen” or “lock windows” makes no difference.

I’ve submitted a bug report via VDMX.

@bada as @2bitpunk mentioned. Displays have separate Spaces should be turned off.

But for me this is a very important feature.
Resoulme doesn’t have this problem, even with this feature enabled. Could you please consider improving this in the future?
I do not think it is a good idea to change the settings and restart the Mac every time you do VJing…

@bada I’ll put it on the feature request list, but don’t know if or when it will happen.

Most users have this turned off in mission control. You can simply login and out again, and ask your mac to reopen the windows on log in. You don’t have to restart your Mac at all.

On an M1 mac, this whole process takes <1 minute to do.

Thank you. I was pretty surprised that I’m the first person to ask for this.
Most of the VJs around me are using “Displays have seprate Spaces” feature. This is essential when working with more than one monitor (such as watching a video in full-screen mode on one monitor and working on another).

1 Like

Mac Studio, M1 Max, 64Gb, 32 GPU cores
VDMX5 Version b0.
Audio routing: Loopback
macOS: 13.3.1 (22E261)

There’s some weirdness happening when running VDMX with OBS. Sliders are jumpy and slow to pickup and when you add FX the controls don’t always appear.

Update / solved: updating Loopback to the latest version looks like its fixed the issue.

Loopback version: 2.2.13
ACE (audio plugin): 11.9.3

1 Like

I found the issue. I had activated Rosetta to use the Waveclock BPM detection and this caused the FX sliders to freeze and react slowly. I could still scrub the slider value and manipulate the layer but the UI was frozen. Turning off Rosetta fixed the issue.