Synchronising clips leads to choppy playback

#1

I am synchronizing multiple identical clips on different layers by ‘Use Data Source > Layers > bottom layer > Normalized time’ on their timelines.

They get synchronized, but it also reduces the framerate of the synchronized layers heavily, so that they appear “choppy”.

What am I doing wrong?

PS: I used this tutorial to learn how to synchronize playback: https://vdmx.vidvox.net/tutorials/syncing-the-playhead-of-multiple-movies-in-vdmx

Br, Dl

0 Likes

#2

Where are you loading all of these media clips from? And external HDD/SSD or your internal HDD/SSD?

Are these clips in HAP or H264?

You’ll want to make sure your media is optimized for your GPU and CPU to be able to handle it.

0 Likes

#3

I am on a Mac Mini 2018 maxed out and using the internal SSD.

I am only loading one single clip, and I am using the same clip on five layers. It’s working - and should work - fine until I try to synchronise the playheads. The GPU and CPU are definitely able to play five instances of the same movie - I don’t see what you mean here. It’s also capable of playing five different clips HAP or H264 on five different layers, for sure.

0 Likes

#4
  • HAP clips will use more of your GPU and internal SSD bandwidth. (test with BlackMagic disk speed test to see your internal read / write speeds). H.264 will pull from your CPU. For troubleshooting it is important to try and balance the load on all the above (SSD, CPU, GPU).

  • How have you syncronized each playhead to the rest? Is one a master and the rest are slaves, or is each a master and a slave?

  • Or are they synced to a custom control surface slider? Or the timecode plugin?

0 Likes

#5

They are synchronised as described above. One is master, the rest are slaves. No sync.
Again, I don’t have any problems running the clip on multiple layers when I am not synchronising them.

0 Likes

Trigger same clip on all layers
#6

If you are using Data Source > Layers > [master source layer] the clips will automatically be synced. There is no UI for a Layer source therefore no playhead. When you scrub the playhead on the master layer the Linked layers will show the same frame.

1 Like

#7

My problem is described in the post above. My clips are synchronised with the master clip, and should play at the same time. They do so, but the synchronised clips are ‘choppy’ - as if the frame rate has been reduced to 5 or so…

0 Likes

Trigger same clip on all layers
#8

Apologies my example was incorrect, the example below follows your description. I didn’t see any issues with the HAP encoded clip I used for testing.

macOS Big Sur
MacBook Pro (15-inch, 2017)
Radeon Pro 560 4 GB
VDMX Version b0.8.7.2.10

1 Like

#9

what frame rates are you getting in your preview windows? You can toggle that setting on in the preview options.

0 Likes

#10

I don’t understand why I am getting choppy playback. There are no problems when the clips are unsynced. Please watch a video of my problem. As soon as I turn on sync, the synced layers play at a reduced frame rate:

https://tonehoved.dk/_VDMX/sync-time-problem--01.mp4

0 Likes

#12

Sorry, I didn’t understand this when you posted it.
Now I get it! This is a quick and effective solution to my problem!
Thank you!

1 Like