MIDI echo doesn't work for two launchpads

#1

Hi,

Tried to use 2 launchpads with different settings, but noticed that MIDI echo is not working when you connect 2 launchpads at the same time.
Is there any way to solve this issue?
I use Macbook Pro with the M1 Max chip.

Best,

0 Likes

#2

https://discourse.vidvox.net/t/vdmx-beta-8-8-0-4-now-ready-for-testing-m1-intel-osx-10-15/1751/2

0 Likes

#3

Just tested this build but still it doesn’t work…

0 Likes

#4

In the MIDI preferences do both launch pads show up? Or are they using the same MIDI CC commands?

0 Likes

#5

yes, both launchapds show up in the MIDI preferences. they are not using the exact same MIDI CC commands, but some buttons are using the same CC/MIDI commands.

0 Likes

#6

In VDMX, what is the MIDI out sent to? Can you configure your launchpad hardware to have different MIDI CC addresses?

0 Likes

#7

I have just tested the build. It is not working. :grimacing:

0 Likes

#8

I’ve configured to have different MIDI CC addresses but it’s still not working.
this is the MIDI out sent to. when you connect just one Launchpad, it’s working. but it’s not working when you use two devices.

0 Likes

#9

Hi @cindyforcia, are you saying you are not able to get MIDI out working on your two launch pads or are you replying in this thread about something else?

If it’s related to b8.8.0.4, please post in that thread so we can keep things organized.

Thanks

0 Likes

#10

@bada,

Can you run Hexler’s Protokol and see what MIDI commands VDMX is sending out and your controller is sending in? If they are sending in the same values and VDMX is echoing back the same values, perhaps something is getting confused along the way?

Let us know what this says. Thanks
https://hexler.net/protokol

0 Likes

#11

I too can’t get MIDI echo working on my LaunchPad with M1.

0 Likes

#12

@laserluke

0 Likes

#13

Oh I didn’t know there was a update! Will try now!!! :)

0 Likes

#14

Definitely working better, but there is still some weirdness going on. The LED feedback seems to work only some of the time.

0 Likes

#15

Can you try running Protokol and see what messages are going back and forth between your device and computer?
https://hexler.net/protokol

1 Like

#16

Yes I’ll give this a try.

My LaunchPad is working properly with midi LED feedback when using it with TouchDesigner, which is what led me to think its a software issue and not the device.

I’ll keep you posted with my findings. Thanks!

0 Likes

#17

Here is a screenshot I just took with my Launchpad MK2

0 Likes

#18

Okay, and if you use both launchpads at the same time, do they show different channels and information or are they identical?

0 Likes

#19

I’m using a LaunchPad and a LaunchControlXL together.

0 Likes

#20

Do both of them work, or does midi echo work only on one at a time?

Thanks

0 Likes