VDMX Beta 8.8.0.4 now ready for testing! (M1/Intel) OSX 10.15+

vdmx
#1

A new update for everyone 10.15+

Remember if you are using 10.14 and older, you’ll want to use the legacy version fo VDMX b8.7.2.4
More details about VDMX versions in the wiki doc: https://docs.vidvox.net/vdmx_versions.html

b8.8.0.4 list of improvements:

  • Fixes a bug that would cause a crash triggering a preset
  • Fixes a bug, local presets for FX chains weren’t clearing FX
  • Advanced fullscreen customization wasn’t working properly (couldn’t edit)
  • Fixes MIDI echo in media bin
  • Fixes drawing padding in media bin
  • A bunch of other bugs involving text input and text parsing
  • Fixes a drawing bug in table headers
  • Other backend changes

More to come in a future update.

Download link: https://www.vidvox.net/download/VDMX5_b8.8.0.4.dmg

Please share your crash logs or bugs using the built in bug reporter located in the Help menu while VDMX is open.

:slight_smile:

3 Likes

pinned #2
0 Likes

Strange UI behaviour b0.8.8.0.0 and 12.2.1 on M1
MIDI echo doesn't work for two launchpads
#3

the midi echo returns !!!
thanks Guys !

1 Like

#4

Wonderful ! had been struggling with the screen output setting and editing text files and importing to get round it

hyped for the MIDI feedback too, been had operating in the dark !

:)

1 Like

#5

Preview stops suddenly after running for a certain amount of time.
There is no problem with external output of sound or video.
Force shutdown required

0 Likes

#6

@genie2600 Could you submit a bug report through the help menu when you have VDMX open? Thanks

0 Likes

MIDI echo doesn't work for two launchpads
#7

Problem

  1. If you upload a clip to the video bin and do not save it, it will be forcibly closed after a certain period of time.
  2. When the designated recording folder disappears, the warning window repeats indefinitely.
  3. After recording, if you click the specified clip page, the ui stops. (Output plays normally)
0 Likes

#8

@genie2600,

Can you capture a video screen recording of this. That would be great!

Thanks

0 Likes

#9

0 Likes

#10

0 Likes

#11

I don’t seem to have this problem. Have you given VDMX read/write permissions for this location?

It’s easiest to turn on Full Disk access in the System Preferences:

0 Likes

#12

Can you share this video clip with me? Is it happening with a specific codec or all codecs?

0 Likes

#13

The file is large and difficult to transfer.
The bug report has been sent.

All rights have been granted.
Intermittent in all codecs (the most used codec is hap)
This is especially the case when you upload a clip to the video bin and use it for a long time without saving it.
There were no problems with Catalina 8.7.2.4.
1pc is Big Sur, 1pc is Monterey, both PCs have the same symptoms
After setting and saving, there is no problem for a while if you use it.
However, I am anxious because I have to use it for more than 10 hours a day every day.

The test mac specs are
imac pro catalina
imac pro big sur
macbook pro 16" monterey

0 Likes

#14

Are you recording to ProRes on all machines? Is that going to an external SSD that your drive is reading and writting off of at the same time? Is it your main SSD? etc. There are multiple variables to what you are saying. In order for us to fix them, we have to isolate exactly what’s going on. Feel free to update the video clip to WeTransfer, which supports 2GB for free or upload an edited piece of it instead of the entire video.

You’re talking about three different systems with very different hardware (Is your 16" Macbook Pro also Intel? or is it M1, running VDMX natively?).

I’m currently on b8.8.0.4 M1 Max MBP running VDMX for more than 10 hours a day as well, and haven’t experienced this, so I’d like to get specifics around your situation so we can try to recreate it.

Thanks

0 Likes

#15

All are Intel CPUs.
Built-in ssd.
I tried all of the recordings in prores h264 pjpeg.
A little while ago, on my m1 iMac, I experienced the media bin freezing while scaling with text on a solid background.

Please send me an email to receive a link
I want to share files on my NAS.

0 Likes

#16

I looked at your MONSTA music video clip and this makes sense why you are having issues. To start, you do not have a keyframe for every frame, in fact it is every 3 frames (more discussed here).

Next you are using the AV1 codec which is not fully supported by Apple. (More on that here. Youtube and Netflix now encode their HD videos in AV1 codec which Apple has not fully adopted in favor of their HVEC codec.

So you’ll need to do two things to for this media to playback correctly.

  • Encode H.264 files with 1 keyframe per video frame
  • Do not use passthru to encode from AV1 to an MP4 or MOV

I’ll take a look at your HAP files shortly.

0 Likes

#17

thank you
Having been using it for a long time, I know the importance of codecs.
The music video was just used because of the too large capacity burden to use the hap codec.
Currently, it is used only for testing purposes.

I’ll remove it or change it to hap and test again

However, it is said that the music video clip was never used in the performance.

0 Likes