Layer Blending Modes - Bug?

Last night during a set I started having an issue with my blending modes - anytime I changed the mode for one layer, it seemingly changed all my other layers to that same mode. Anyone experienced this before?
For more details, I had about ~5-6 layers, with inputs varying from Chrome windows to loaded files. I had some using ‘Over’, some with ‘Add’, some with ‘Difference’. I was also using a layer mask for one layer, though I would check to make sure both the mask layer & the content layer had the same blending mode.
For whatever reason, my Preset didn’t save (side issue) so I’m having trouble going back to inspect the project. Any insights greatly appreciated! xx Loaf

1 Like

Oh, I have actually experienced something like that, wasn’t sure if it was a bug or a limitation:

For example in a new project, add a second layer (both should have blending mode “OpenGL- Add” by default) then change the blending of the 2nd layer to anything under CoreImage or GLSL, it will also change the 1st layer to the same blending group (CoreImage or GLSL).

Is this a limitation that layers must use the same kind of blending whether OpenGL, CoreImage or GLSL? Or possibly a bug?

I also noticed that if you group these layers, they won’t affect the group’s blending, but then the group and any additional layers at that level will also affect each other.

1 Like

Oooh, interesting thought. Definitely seems likely that it’s a limitation and not a bug.
Thanks for the input, Marc. Will report back if I discover anything else.

Yea I have been wondering the same. Layers “touching “ always seem to need the same blend.

So does this mean to get seperate blending types layers must be in separate layer groups?

To clarify this point…

Within a ‘group’ of layers, the OpenGL Add / Over modes are mutually exclusive with the more advanced composition modes (CoreImage, GLSL, Quartz Composer). VDMX will automatically switch the comp modes for layers within a group to handle this.

A few notes:

  • You will get the best performance when using OpenGL Add & Over modes. Use these whenever possible, especially for very high resolution situations!
  • If using the more advanced options for composition, we recommend using the GLSL modes whenever possible (here is a tutorial on making your own GLSL comp modes, https://vdmx.vidvox.net/tutorials/making-glsl-composition-modes-for-vdmx)
  • The VVSourceAtop.fs is the closest match to OpenGL Over mode.
  • This is a subtle detail in advanced cases – when you are doing compositing with multiple sub-groups of layers and you are using both alpha channels and opacity for blending, and you need the alpha channels to be preserved when that sub-group gets composited with other layers or groups, within your sub-groups you may need to use the GLSL modes instead of the OpenGL Add / Over modes. I can post an example of this to demonstrate if it’d be useful.
4 Likes

Thanks for the clarification David! That helps understand it well. Also good to know what to stick with for high resolution stuff!

Hey @davidlublin I would love to see an example just to clarify exactly what your talking about … and what situations you may want to use the GLSL Modes.

thanks

RE: OpenGL v GLSL modes -
OpenGL modes do not work on my machine at all…
eg 1 - open new project, add live cam feed -
by default layer is set to OPEN GL ADD - and the screen is black.
Switching to GLSL - VVSourceAtop - makes the webcam visible.

eg 2 - Open various templates - they’re set to OPEN GL by default - and don’t display anything…
Switching to a GLSL mode makes them visible…

Is this an issue with my machine ( 2019 MBP ) or install?

Or is there a way to globally set a default blend mode, when opening any layers?

:sparkles::pray:t3:

Hi Jean,

What version of VDMX are you running, and which version of OSX?

HI - sorry, forgot to mention that - 10.15 + VDMX 8.8.0.5 (but this behaviour has been happening for me across all of my versions of VDMX over the last year or so… )

This is SO helpful, thank you for writing this up. I was just struggling with this yesterday, where a group needs their alpha preserved. But, even if all layers are set to “over”, and all have a nice alpha, and the group is set to over… there’s still no alpha getting out of the group.

Will try with the VVSourceAtop.fs through the layers in the group. Thanks again.

1 Like

sorry, forgot to mention that - 10.15 + VDMX 8.8.0.5 (but this behaviour has been happening for me across all of my versions of VDMX over the last year or so… )

Is this an issue with my machine ( 2019 MBP ) or install?

Or is there a way to globally set a default blend mode, when opening any layers?

Hi there. I don’t think so. But, what do you mean by, “…opening any layer”? Layers are always “open”. And, every layer has a blend mode. If you mean when you create a new layer… then I just checked and didn’t see a default setting for this. The OpenGL modes are what I use about 75% of the time. They work fast and well with one another. That’s why they’re the default is my guess!

Hi Seejordan - Yes, I meant ‘create new layer’ -
unfortunately I get black screens when i create new layers set to open GL by default,
and need to switch to a GLSL blend mode to get any visibility…
Am just trying to figure out ways to avoid that extra step…