VDMX macOS X 13 Ventura Update Guide

Updated (2.6.2023) Hello all, we are still testing Mac OS Ventura for VDMX. Right now there are UI bugs with vertical sliders and various fonts. If you are running OSX 13, please use the latest version: https://discourse.vidvox.net/t/vdmx-beta-8-8-0-6-now-ready-for-testing-m1-intel-osx-10-15/

We currently do not recommend that you upgrade until we’ve done more testing, worked through bug reports, etc. If you do plan on installing the latest version, or have already done so.

  • Don’t update if you’re in the middle of a big project that might get disrupted.
  • If possible make a total bootable backup of your system (I like https://bombich.com/), and / or;
  • If possible do the install on a secondary partition so you can switch back if needed.
  • Send us bug reports if things go wrong!

Please submit any bug reports through the built in bug reporter via the help menu when VDMX is open.

If you are currently on Mac OSX 13 Ventura, please share your experiences here. It appears to be similar to Monterey, but we’re not sure of all the changes Apple has made on the backend that may affect VDMX in one way or another.

We did some testing and Ventura is not fully compatible with the latest build of VDMX natively or under Rosetta 2.

We’re still working on a few more updates for a new built of VDMX that should hopefully eliminate some issues that you’ve experienced with b8.8.0.5

If you’re on Ventura and like it – let us know your thoughts below.

-The VIDVOX Team


thanks for the heads up ! Good luck.

I made the mistake to update my MacBook Pro 2019 to Ventura 13 and now VDMX won’t open. Every time I try it just says “VDMX shut down unexpectedly.” I’m able to see the code information about the shut down and can send a report to apple, but otherwise I don’t know what to do.
I just saw your post here now and definitely regret updating. Do you have any suggestions for things I should try or just wait for a new VDMX update?

First I would recommend deleting the VDMX app (drag to trash, remove), then reinstalling from the latest binary (b8.8.0.5).

I’d make sure that VDMX has security permissions, such as all disk access, and files and folders, access to camera and microphone, etc.

It’s hard to say, but OSX updates can make a lot of changes that throw everything out of whack.

Let us know how it goes.

I wish I have seen this thread earlier hahaha… I’m here to report a bug I encountered on one of my biggest shows for this year… :sweat_smile::sweat_smile: Let’s just say my heart nearly came out during the whole show haha…

First of all, in all of my layer sources, I cannot see the volume control UI. It’s there, if I put my mouse on it, I can still control it, I can also right click and assign midi detect etc. But I just can’t physically see the UI of the volume.

And secondly, this is also the scarier part, is after a few minutes of using VDMX, all right clicks don’t work. It works, but I can’t see anything when I right click. Basically the menu still exists, I just can’t see it, I found this out because when I right clicked, nothing came out, and then I accidently clicked a random spot again and it still triggered one of the selections of the right click menu. So, the menu is there, I just can’t see the UI, same with the volume control in layer sources. Also, when right click stops working, the Menu bar on top also does not show anything when I click on the menu items like “File” or “VDMX” etc.

And lastly, VDMX will randomly just… not play anything. It will sometimes randomly stop working. When I trigger my MIDI pad, nothing happens, and when I go to manually mouse click on a clip in a Media bin, the clip in the media bin goes red, suggesting it’s activated, but nothing plays.

So these were the three main bugs I came across when using VDMX on Ventura. The last two bugs nearly gave me heart attacks during the show haha… I was constantly restarting VDMX and my laptop during rehearsal haha…

P.S: The show still ended up going smoothly. The rehearsal was a mess though, but thank god the third bug I mentioned didnt occur during the actual show, clips played as they should during the show. The menu UIs and stuff disappeared, but that didnt bother me once everything was setup.


Thanks for filling us in. After you updated did you reinstall VDMX to make sure there were no code signing errors?

Also, did you re-enable all disk permissions for VDMX (which may need your approval before VDMX can access the disk properly).

Let us know how it goes. Thanks!

That’s a very good point. I didn’t check any of that. I will uninstall and reinstall VDMX now and re-enable all permissions and play around with it. Will get back to ya.

I am back with an update.

After uninstalling and reinstalling VDMX, I can confirm that I can still not see the volume control in Layer Src when playing a media. It’s there, I can stil control it, but the UI is not visible. I am running Ventura.

Here is a screenshot:

As you can see, there is no visible UI for volume control. However, if I put my mouse over that part and click and drag, I can still control the volume.

Full Disk Access is enabled.

1 Like

Thanks for sharing. Yes, other users are rolling back to OSX 12 Monterey where VDMX is stable.

Unless purchasing a new laptop, it is not advised to update OSX so soon after the launch. Lots of bugs and fixes that will need addressed.

Will there be an update for VDMX soon with full support for Ventura?

Unsure when that will be. There was already an update planned to be released soon with multiple fixes, but this will throw a curve in the timeline and requires more testing.

updated to Ventura, VDMX installed and seems to work fine.

Which version of Ventura and VDMX are you running?

Ventura 13.1

Are you running Apple Silicon or Intel? Thanks

Arm (at least 20 characters)

Any update on a VDMX for Ventura update?
Also having the issue with vertical sliders not showing.
running b8.8.0.5

1 Like

I too am desperately waiting for a Ventura update. Feels like the update cycles are becoming longer and longer.

The vertical sliders not showing I’ve also noticed doesn’t show up anywhere, including in the custom control surface, if I make an UI element vertical, it disappears (it’s there, I can control it, I just can’t see anything, it becomes invisible), but if I change it back to horizontal, it appears again.

But currently the most annoying bug for me is that menu items (anything with a popup menu, whether it be from a right click, or from the top menu bar) randomly stop showing up every now and then, and can only be fixed through a VDMX restart. This is a scary nightmare during shows.

1 Like

Take a look at: https://discourse.vidvox.net/t/vdmx-beta-8-8-0-6-now-ready-for-testing-m1-intel-osx-10-15/