VDMX Beta 8.7.2.11 now ready for testing! (M1/Intel)

m1
vdmx
#1

Hey Everyone!

We have a new update for you to try out!

It’s a universal build for both Intel and M1 Apple Silicone Macs.

A few things to note:

  • Waveclock does not currently work on M1 Macs (it should on Intel)
    If you are on an M1 Mac and need WaveClock to work, you waveclock you must set the app to run under Rosetta (using Get Info on the app in the Finder).

  • A few QcFX will not work on M1, but should on Intel. (Running under Rosetta should fix this)

Once again as always, If you run into any problems, please use the “Report Bug” option in the Help menu.

Download here:
https://vidvox.net/download/VDMX5_b8.7.2.11.dmg

Thanks!

10 Likes

pinned #2
0 Likes

#3

This build is a game changer for M1 macs. everything is so smooth now. thanks for your hard work vidvox team!

1 Like

#5

I cannot event open it :grimacing: !!
vdmx app icon jumps and then nothing, just this:


.
maybe I will get back to the previous one, and wait a bit.
I should also probably update my OS. !!!
.
My system:
Mojave 10.14.6
MacBook Pro (15-inch, 2018)
2,2 GHz Intel Core i7
Radeon Pro 555X 4 GB

0 Likes

#6

If you can’t open it to send us a bug report, could you email support at vidvox.net so we can follow up?

Thanks!

1 Like

#7

Just sent it.
sent in attachment a txt file with the apple error report

1 Like

#8

Thanks @ProjectileObjects! – I just received my new M1 and will be putting this through a few tests soon!

0 Likes

#9

Hi.
It seems to be working fine on my M1Macbook, so far.
Thanks for the kind update.

1 Like

#10

I’ve been running on a M1 Mac Mini for two weeks straight testing it out for a possible install.

0 Likes

#11

Same here, I stresstested this build on my M1 Mac Mini over the weekend, behaved exceedingly well.

0 Likes

#12

Yeah instant crash / doesn’t even open.
Console says segmentation fault.

OS Version: Mac OS X 10.13.6 (17G14042)
Crashed Thread: 2 Dispatch queue: WebCoreAudioVisualMIMETypes loader queue

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x000024a500007cb0
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [0]

0 Likes

#13

Yeah my Macbook M1 Max all souped up crashes on open. The .10 build crashes too. Had to go back to the .4 build I has but my visuals are choppy :persevere: running 2 projectors.

0 Likes

#14

Every once in a rare while, for some still unknown to us reason, running an update messes up the code signing of the app; fortunately this is easily fixed by deleting the app and then just re-installing from the latest dmg.

If that doesn’t do the trick, we’ll need two pieces of information to get the ball rolling on diagnosing the issue.

  • A ‘Stack Trace’: You can get one of these by opening Activity Monitor, then launching VDMX, and then when it hangs, use the ‘Sample Application’ option in Activity Monitor, and save that to send to us.

  • The ‘Console Logs’: You can find these by using the ‘Go To Folder’ option in the Finder, and going to “~/Library/Logs/VDMX5”, and send us any recent logs that seem like they correspond to the hang.

0 Likes

#15

It seems MIDI send is not working in this build (M1)

3 Likes

#16

Looks like it is generally fine with MBP A2485. Re-installed. Working SO fast on new machine! Amazing, no preload needed for more than 1000 clips in the Bin and no lag from triggering!
Midi Echo is not working, no colours on midi controller with Note On/Off. Hard to operate the show in the dark, but thanks for update, my favourite app is usable… Many other apps or plugins are not working or buggy with new M1 pro.
Hope it is possible to fix midi issue.

1 Like

#17

I have not put it through a proper test BUT it is working better. Before this update the videos would play but then pause if I changed their speed faster or slower.

Thank you!

0 Likes

#18

That sounds like a video codec issue. I’m assuming you are using H264 or H265 in the case. With H264 and a keyframe for every frame I cannot push a video past 2x play speed. With HAP you can go the full 5x+.

0 Likes

#19

You are right. I just don’t want to mess up my HD space by using HAP.

0 Likes

#20

Make sure to encode your H264 video files with a keyframe for every frame or put the HAP files on an external drive.

1 Like

#21

How about for the crashes on launch?

0 Likes