Unable to Open VDMX all of a Sudden

#1

So unfortunately my VDMX on my M1MAX 64gb version just stopped opening. I was working on a project and closed it, tried to reopen it and now VDMX just keeps crashing as soon as it starts loading a project unable to even click anything. Kinda freaking out as I need VDMX to work for me by Wednesday for a festival. Even updated my OS to 12.4 beta and still same results

0 Likes

#2

I reinstalled VDMX and sometimes loads the clips but won’t let me Enter the Serial number again as it gives me the color wheel so I’m just stuck in Register Me mode

0 Likes

#3

BUG REPORTDate/Time: 2022-05-09 23:38:42.741 -0500
End time: 2022-05-09 23:40:23.430 -0500
OS Version: macOS 12.4 (Build 21F5071b)
Architecture: arm64e
Report Version: 35.1
Incident Identifier: B8F05AF7-609D-4D84-A63C-7E2EB4405EDB
Share With Devs: Yes

Data Source: Stackshots
Shared Cache: 3A777540-8C73-3790-9415-21722EC04B47 slid base address 0x1a2a04000, slide 0x22a04000
Shared Cache: C426548D-AB5F-36B7-8E3A-9187A3F45C3B slid base address 0x1ee524000, slide 0x6e524000
Shared Cache: D8464BC2-595B-3C05-8C95-58BB161B998A slid base address 0x7ff818360000, slide 0x18360000

Command: VDMX5
Path: /Applications/VDMX5.app/Contents/MacOS/VDMX5
Identifier: com.vidvox.VDMX5
Version: ??? (b0.8.7.2.13)
Team ID: KH97KZU7A7
Architecture: x86_64 (translated)
Parent: launchd [1]
PID: 1660
Time Since Fork: 159s

Event: hang
Duration: 100.69s
Duration Sampled: 1.21s (process was unresponsive for 100 seconds before sampling)
Steps: 12 (100ms sampling interval)

Hardware model: MacBookPro18,2
Active cpus: 10
HW page size: 16384
VM page size: 16384

Time Awake Since Boot: 875s
Time Since Wake: n/a (machine hasn’t slept)

Fan speed: 0 rpm
Total CPU Time: 2.539s (3.8G cycles, 6.8G instructions, 0.55c/i)
Advisory levels: Battery -> 2, User -> 2, ThermalPressure -> 0, Combined -> 2
Free disk space: 804.10 GB/926.35 GB, low space threshold 3072 MB


Timeline format: stacks are sorted chronologically
Use -i and -heavy to re-report with count sorting

Heaviest stack for the main thread of the target process:
11 start + 462 (dyld + 21790) [0x200ffd51e]
11 ??? (VDMX5 + 32694) [0x1003cdfb6]
11 NSApplicationMain + 817 (AppKit + 16103) [0x7ff81b07eee7]
11 -[NSApplication run] + 586 (AppKit + 196457) [0x7ff81b0aaf69]
11 -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 1394 (AppKit + 252090) [0x7ff81b0b88ba]
11 _DPSNextEvent + 927 (AppKit + 258557) [0x7ff81b0ba1fd]
11 _BlockUntilNextEventMatchingListInModeWithFilter + 70 (HIToolbox + 188645) [0x7ff8218580e5]
11 ReceiveNextEventCommon + 594 (HIToolbox + 189258) [0x7ff82185834a]
11 RunCurrentEventLoopInMode + 292 (HIToolbox + 189926) [0x7ff8218585e6]
11 CFRunLoopRunSpecific + 562 (CoreFoundation + 512020) [0x7ff818745014]
11 __CFRunLoopRun + 2014 (CoreFoundation + 515762) [0x7ff818745eb2]
11 __CFRunLoopDoTimers + 307 (CoreFoundation + 620107) [0x7ff81875f64b]
11 __CFRunLoopDoTimer + 923 (CoreFoundation + 621287) [0x7ff81875fae7]
11 CFRUNLOOP_IS_CALLING_OUT_TO_A_TIMER_CALLBACK_FUNCTION + 20 (CoreFoundation + 622582) [0x7ff81875fff6]
11 ??? (CFNetwork + 1045709) [0x7ff81d15e4cd]
11 -[VVOSCQueryServerDetectorDomain netServiceDidResolveAddress:] + 100 (VVOSCQueryProtocol + 217194) [0x10b8f206a]
11 -[VVOSCQueryServerDetector serviceResolved:] + 167 (VVOSCQueryProtocol + 359631) [0x10b914ccf]
11 -[VVOSCQueryRemoteServer initWithWebServerAddressString:port:bonjourName:] + 1257 (VVOSCQueryProtocol + 342704) [0x10b910ab0]
11 -[VVOSCQueryRemoteServer _finishInit] + 33 (VVOSCQueryProtocol + 342997) [0x10b910bd5]
11 -[VVOSCQueryRemoteServer hostInfo] + 192 (VVOSCQueryProtocol + 345993) [0x10b911789]
11 -[CURLDL _performWithDelegate:] + 38 (VVOSCQueryProtocol + 324590) [0x10b90c3ee]
11 -[CURLDL _execute] + 744 (VVOSCQueryProtocol + 326392) [0x10b90caf8]
11 curl_easy_perform + 285 (libcurl.4.dylib + 140371) [0x7ff82d3e0453]
11 curl_multi_poll + 26 (libcurl.4.dylib + 176879) [0x7ff82d3e92ef]
11 multi_wait + 759 (libcurl.4.dylib + 176500) [0x7ff82d3e9174]
11 ??? [0x7ff8a8bfa940]
*11 ??? (kernel.release.t6000 + 5987592) [0xfffffe0007e5dd08]

Process: VDMX5 [1660]
UUID: BDC1E0C8-FD45-3D2A-9981-0CF30CF2740D
Path: /Applications/VDMX5.app/Contents/MacOS/VDMX5
Identifier: com.vidvox.VDMX5
Version: ??? (b0.8.7.2.13)
Team ID: KH97KZU7A7
Shared Cache: D8464BC2-595B-3C05-8C95-58BB161B998A slid base address 0x7ff818360000, slide 0x18360000
Architecture: x86_64 (translated)
Parent: launchd [1]
UID: 501
Footprint: 180.28 MB -> 156.92 MB (-23.36 MB)
Time Since Fork: 159s
Num samples: 12 (1-12)
CPU Time: 0.477s (662.0M cycles, 954.4M instructions, 0.69c/i)
Note: Suspended for 2 samples
Note: Terminated (zombie) for 1 sample
Note: Unresponsive for 100 seconds before sampling
Note: 35 idle work queue threads omitted

0 Likes

#4

Hi, the latest beta for your OS is b8.8.0.0. Looks like you are running b0.8.7.2.13

When you reinstall, don’t install overtop of your existing version. This doesn’t remove all the files or replace them.

First, drag and drop your VDMX application into the trash and remove. Then install from the latest DMG. IF you want to be extra safe, restart in between.

Latest beta here: https://vidvox.net/download/vdmx_demo

0 Likes

#5

So I had installed 8.8.0.0 before the bug report and it would crash still so I redownloaded. I honestly didn’t do anything when I opened the project up today again and it started working. Im just nervous now opening VDMX because I have no clue if its going to start crashing or not

0 Likes

#6

Hard to say what’s causing it.

I use VDMX (multiple versions) daily, and I haven’t had a crash in over a year (it was more of a hang, but I force quit). It seems like the few reports of crashes with VDMX are with older Intel macs with Monterey, or pre 10.14 mac’s not running b8.7.2.4. I wonder what Apple’s doing on the backend.

Could you send a bug report through the help menu next time you have VDMX open?

Thanks

0 Likes

#7

This sort of thing is happening to me as well. I might get a few minutes of VDMX on my M1 Mac Mini but it’s quickly ended by a spinning beachball and crashes. I now have my older Intel Mac Mini set up on a folding table near my regular desk running VDMX. I’m glad I have the back-up option but I’d love to run a non-Rosetta stable build on my M1 Mac Mini someday. I know it’s a small team of geniuses over there and it’ll iron out someday. I really just don’t want to go and learn Max MSP. You guys already have all those nice sliders and doo-dads. Anyway, good luck squashing bugs.

0 Likes

#8

I once got a similar issue when I quit the app in full screen and restarted with another screen setup. ESC helped…

0 Likes

#9

Hi @ellingson,

Could you send us a bug report with the built in help menu, and we’ll reach out and try to get those crash logs from you.

Thanks!

0 Likes

#10

Sure, I’ll give it another shot. I tried to fill out the crash report box a couple of times and it crashed while I was typing.

0 Likes

#11

Ouch, at least there should be a crash log you can pull out of that to send to us? support at vidvox

0 Likes

#12

It seems that on my machine, VDMX hangs at startup or crashes shortly after if there’s an incoming MIDI signal to my M1 Mac Mini while it is launching. If I make sure that my CV-to-MIDI devices isn’t sending a pulse and then start VDMX, it seems to behave okay. I submitted a support email about it but I’m replying here in case it’s helpful to others.

1 Like

#13

Also, just fyi that I’m running VDMX under Rosetta.

0 Likes