ProjectMilkSyphon suddenly crashes and/or freezes constantly on startup (Apple M1 Pro running Monterey)

Hello, all! After a year or so of having no issues running ProjectMilkSyphon periodically as part of virtual VJing, I am suddenly unable to use it due to constant crashes and/or freezes upon startup. I’ve included my basic specs below:

MacBook Pro (16-inch, 2021)
Apple M1 Pro
32 GB
12.6.8 (21G725)

For more details, I have included the crash report below. If anyone has any ideas as to how I might rectify this, I would be greatly appreciative (as I know this is free software already being provided generously to the community). Thank you in advance for any time and consideration you can offer!

ProjectMilkSyphon Crash (10.8 KB)

I think it needs an update. I haven’t been able to get it to work with my internal microphone since buying an M1 mac. Maybe it’s a permission / privacy setting?

I knew a few presets were not compatible and would lead to crashes. Perhaps yours got stuck on one of those presets?

Are you dragging it to an external monitor or screen?

Thank you so much for the response! After reading your message, I did some troubleshooting and deleted the preset that was loading right before the crash. And it worked! That made me think I did only get stuck on a preset. However, after more use, presets that successfully loaded before suddenly started crashing ProjectMilkSyphon. I then attempted to delete all but one preset that was working, and that also worked once or twice before starting to crash. As mentioned, I have done some system-scouring uninstalls of the app as well, with no success.

Until just recently, I successfully used ProjectMilkSyphon for about a year on my M1 mac, with microphone permissions enabled and piping in sound through Loopback. I am using it on my laptop screen only (normally, I am sharing the video with other applications via Syphon). The only thing that really changed of any significance in my system is installing a Monterey security update.

Ouch. Well that was most likely it. Something in the update broke your ability to use ProjectMilkSyphon. Apple is notorious for doing that with OSX changes, but I’ve noticed more and more that any update from Apple is a risk for a stable operating system. I don’t remember if it was 12.6.4, but there was one update that made VDMX crash on all 64GB M1 Macs. (Only the 64GB versions, not 32 or 16).

If you have a time machine save, I would roll back the update, otherwise you might have to write a new app yourself.

I’d also try to clear out the Library/Cache and Preferences related to the ProjectMilkSyphon app.

Thank you for the suggestion. Can you specify what you mean by clearing the library/cache? I deleted all files relevant to the app using AppCleaner, as well as deleted all the presets before reinstalling.