Non-HAP QuickTime codecs fail to import to VDMX (b0.

I’m currently unable to import non-HAP QuickTime MOV codecs into VDMX. Same files play back fine with VLC, Quicktime Player and AE. Tried exporting ProRes 422 & 4444, PAL DV (edit: PAL DV works) and DNxHR as MOVs from AME 2020. Only one that loads is Uncompressed 8-bit RGB but even that won’t display, just playhead running.

I’m running b0. on MBP 2016 with macOS Mojave 10.14.6. Updated Creative Cloud today to the latest AE and AME. Any ideas where to start digging?

A few notes…

  1. Several years ago we switched from using QuickTime to AVFoundation for movie playback in VDMX. As such only codecs supported by AVFoundation (plus HAP) are supported. A good rule of thumb is to try opening the file in QuickTime Player X, not the older version 7.
  2. In order to use ProRes in VDMX (and other AVF based apps) you must install the Pro Video Formats add-on from Apple,
  3. Check out the VDMX manual section on video codecs for more information:

If you are having trouble with specific clips you think should load, feel free to send them to us along with a bug report!

PS. As an aside, even in the past we typically recommended against using codecs like DNxHR that aren’t optimized for use.

Encoding to Prores works now, after few reboots. Previously rendered clips won’t work for some reason.
Attached a link to one offending Prores MOV: