Infinity knob in control surface


#1

Hey.

I use an APC-40 as my primary midi controller with vdmx.
I’ve just made a complete layout of the controller in a control surface to save as .JSON for sharing with friends who also use the APC-40.
The problem is, when I’m mapping all the buttons and sliders I get stock at that infinity knob placed above the Master Fader called Cue Level.
I’ve made it as a slider in the Control Surface but I can’t seem to get it to work correctly, without the slider jumping everywhere by the time I touch the actual knob on the APC.
I’ve tried all possible combinations of tick marks in the UI Inspector, but it doesn’t work…

Anyone has an answer to this?


#2

If you look in the sub-inspector for receivers you’ll find an “Endless MIDI Mode” option like in the attached screenshot.

There is no official convention for endless MIDI, but it usually comes in one of a few varieties (some knobs send off different values depending on the rate / direction you turn, others send off individual ‘ticks’ of different sorts). You can either go through each of the options until you find the right one, or use a Comm Display plugin to snoop the data to make an educated guess.
(sorry I don’t recall offhand which setting works for the APC40; it’s bit much to dig out of the gear closet to plug in at the moment, but if you’re still stuck let me know and I’ll grab it)


#3

Hey thanks for answering David.

I’ve tried the method you describe, by going through the list of “Endless MIDI Mode” but without luck… Nothing seems to work. I don’t want you to use a lot of time, finding your gear in the closet if you don’t got the time. You are welcome to try if you have the time though.

I’m beginning to think that my controller might be broken or something…

/J


#4

Seemed to work as expected for me with the APC using the “127/1” mode – I’ve attached a video of this and the project file which you can test out on your own.

APC-EndlessTest.zip (14.3 KB)

I’d also suggest MIDI Monitor as a 3rd party app that can snoop on incoming values,
https://www.snoize.com/MIDIMonitor/

Beyond that, if you’re still having issues (and it doesn’t look like a problem with the actual controller itself) perhaps you can follow up with us on email via the Report Bug option in the Help menu.


#5

Thank you!
I’ll test it when I’m at the machine again.


#6

So, I tried to do as shown in the video. I didn’t work. But it DID work, after I opened the controller and used compressed air all over the components…

So problem solved. Thanks for your helt and time.


#7

Glad to hear you got it working, and as an added bonus now I have a reference for when I want to just blame something on the hardware in the future :smile:


#8

Haha… funny. ;)
The knob is broken again by the way…


#9

jorg_cph, I’d love a copy of your APC-40 control surface .JSON.

I’m using the same controller along with a Novation Launchpad XL