(FYI) VDMX M1 64GB M1 Max Monterey 12.2.1 OSX Bug


I’m also having VDMX suddenly stop working on an M1Max. Was on an intel version in rosetta, getting a terrible bug playing back mp4 video (video always starting back at frame 1 after pause while audio continued from pause position). Updated to each of the M1 compatibles up to .14, each of which failed to open, as did, when reinstalled the intel. I sent the crash reports via an address found on the site for submitting bugs, as there was no way to open the program and send from there. Alas, this is at a very critical time (using vdmx to demonstrate video processing concepts to a class I’m teaching).
I’m no crash report expert but each was similar and seemed connected to something involving vuo files (which I don’t use).



could I send it through here or email it to you



You can post it here on the forums. Upload the .vdmx5 project or compress it and upload the .zip



also its just a random file name i chose that resembles what the effect should look like

1 Like


I opened up this project natively on an M1 Max Macbook Pro running VDMX b8.7.2.13

All the FX are working on my end, including the blend modes.

What video codec are you using? I also noticed your layers are slightly offset in their outputs.




I believe most files are either mp4 or mov.



It looks like its definitely something through my end, then. Its just random because they were working before. I can only play the clips mainly without any effects. Could it be a setting I might of set off by accident



If you have another project you’d like me to test, please upload it with a clip that you have that doesn’t work. I’ll see if I can recreate it on my end. (Maybe it’s a clip + FX issue?). Would be good to have both.




So even upon starting a new project, seems like the same things happen. Is there a way to check if the FX are still there like in a folder? Im assuming they would still be there though after you install vdmx so its just got me in quite a conundrum



Apologies for jumping into the middle of this thread, but for those having this problem; do you happen to be using the 64GB version of the M1 MAX?

If so, then you may be tripping over an OS video bug that only seems to affect the 64 GB version of the M1 MAX when using macOS 12.2. The problem was noticed in mimoLive users (which I also use) where Program Out would display only black (which is less than ideal), and it was tracked down to a bug in the OS.

Support thread:

and official announcement:

To work around the problem either boot from a 12.1 partition (instructions linked in the announcement) or install the macOS 12.3 beta (currently beta 5). I have tried both, and both work for me.

Also, I can confirm that the project above (LUMEN diffusionFX) works on my MBP M1 MAX 64GB using macOS 12.3 beta 5 and VDMX b8.7.2.14.

Hope that helps…



Oh wow I actually am using the 64gb version of M1Max. Thanks so much for this I am going to try this and post my results.


pinned #18


Going to 12.3(beta 5) fixed the issues I had before. So stoked to have this running again. Thank ya’ll so much for the help and patience with me. :pray:

1 Like


Thanks for posting your Q on the forums. I’m glad the community (@keith) helped figure it out! I’ve pinned it so others can see it as well.


VDMX Crashes on startup - MacBook Pro M1 Montery

Hello Keith… i am having trouble getting my VDMX5 to even open.

I just got the 64gig MACbook Pro and am running Monterey 12.3

Do you have any ideas what I can try to get the program to open? I am in a bit of a jam as I need to start a project today.

Thank you very much,




I think that I figured it out. I did not have the latest version of VDMX5.

I will let you know if this does not work.

1 Like


Thanks for this thread ! was struggling with a recently purchased M1 Max 64GB, hadn’t updated its stock OS and I had VDMX display output issues, which updating to Mac OS 12.3.1 seems to have solved ! wonderful was begging to worry an M1 was bought too soon, but thrilled to see 120fps in the main output window now :nerd_face:



Does anyone know if this issue has returned in 12.4? (Anyone running 12.4 and .qtz FX are working fine?). Thanks



Running 12.4 beta at the moment and seems to be working well for me.



12.4 is out of beta, and the current build. Thanks