VDMX Crashes on startup - MacBook Pro M1 Montery



I’m trying to setup my new MacBook pro M1 32 GB (N2D7GCM7YV).
But the app keeps crashing. I’m having a Gig next week so really need this to work :)

Any suggestions? I just downloaded the latest version of VDMX: VDMX5_b8.7.2.14

I can share crashreport, but can’t do it here since it has to many characters.



Feel free to share the crash report in a zip file



I’m having the same issue. I tried opening with Rosetta too and it crashed either way. I’ve attached my crash report VDMX5 Crash report.zip (9.2 KB)




Attached my crash report.
Hope there can be a fix soon so I don’t need to cancel my gig :)
lucas-vollebergh-crash.zip (9.2 KB)



If you roll back to a previous version. For example b8.7.2.11, does it work?



What are your system specs?



I dont mean to hijack your thread Lucas! Should I start another?



What are your system specs? b8.7.2.14 hasn’t been released on the forums. The only difference between b8.7.2.14 and b8.7.2.13 is a vuo update. And in your crash log the same issue popped up:

Application Specific Information:
t= 0.7813s VuoGlContext.cc:627 VuoGlContext_setGlobalRootContext()



Im on a Macbook Pro, Apple M1 Pro chip, 16 GB ram, running macOS Monterey 12.2.1



Does it work if you install b8.7.2.13?



Negative, same result. Crash report attachedVDMX 5 Crash.zip (8.8 KB)



Looks like it is a similar Vuo crash. A few things to try:

  • Uninstall / completely delete VDMX and remove any installed folders in Application Support.

It’s possible that you installed b8.7.2.13, but the version of Vuo installed is still newer? (I could be wrong)

You can also try to make sure your version of VDMX isn’t attempting to open up an existing project on launch. To do this, locate your VDMX project folder in documents, change the name and move it elsewhere.

Do you have Vuo installed on your machine?

Crashed Thread:        0

Exception Type:        EXC_BREAKPOINT (SIGTRAP)
Exception Codes:       0x0000000000000001, 0x000000018c8263c0
Exception Note:        EXC_CORPSE_NOTIFY

Termination Reason:    Namespace SIGNAL, Code 5 Trace/BPT trap: 5
Terminating Process:   exc handler [17899]

Application Specific Information:
t=  0.5556s             VuoGlContext.cc:616         VuoGlContext_setGlobalRootContext()  Setting global root context to 0x12d103200
Assertion failed: (NSViewIsCurrentlyBuildingLayerTreeForDisplay() != currentlyBuildingLayerTree), function NSViewSetCurrentlyBuildingLayerTreeForDisplay, file NSView.m, line 13477.


Thank you! I dont have Vuo installed on my machine. Which version of VDMX should I clean install?



I’d try b8.7.2.11 and if that doesn’t work, then you’ll have to go back further. such as b8.7.2.9 or b8.7.2.7 (Rosetta 2 only).

If you can get it to launch correctly, then b8.7.2.13 should work perfectly on your system.

I’m not sure about the M1 Pro Macs but there’s an OSX issue with 64GB M1 Max macbook pros. See here, how to roll back your OS or install the latest beta to fix the issue:



Ok sounds good. Where do I get b8.7.2.11?



Hi guys,

I tried:

  1. installing, did not work
  2. deleting VDMX and reinstalled: this worked, did had to look for my licence

Thanks @ProjectileObjects
@gregsinibaldi, no worries :) hope you’ll find a solution to.

1 Like


FYI a clean install of works! Thanks for the help @ProjectileObjects and @Lucas

1 Like


Hi – I just upgraded to and VDMX crashes as it loads, before seeing any load screens (the icon bounces for a second or two, then blinks and has quit). I’m running Mojave Mac OS 10.14.6 on a 2019 Intel i9 MacBook Pro (can’t go past Mojave because of software I use for work) – so not sure if I should post in this thread, but seemed relevant.

I tried uninstalling the app and application support folders in my user library and root library, and installing Did not work. Uninstalled and tried Did not work. Uninstalled and tried again. Restarted. Did not work.

Any ideas? Thanks



Please install the version that works for your OS. You can see it all here: https://docs.vidvox.net/vdmx_versions.html

We’re working on fixes to address this on future updates, but unfortunately there are changes in the latest builds that are not compatabile with older versions of OSX.


#20 worked – thanks! I thought I’d been keeping up to date (I use VDMX regularly), but maybe I missed a few updates…? In any case, all is well.

Now if only my industry would catch up to a more current OS…

1 Like