Displays have separate spaces (am I going mad?)

MacBook Pro 2017
macOS Ventura 13.6.3 (22G436)
VDMX5 b0.

Ok, so its that quiet month when we don’t plug in projectors so I might be being dumb, tired, senior moment, whatever. But I seemed to have the reverse happening on my MacBook for “displays have separate spaces”. Normally I have it turned on (enabled) to hide the VDMX menu on external screens but on this MacBook I have to turn it off to hide the menu? Has my UI gone all alternate dimension on me??

Update: When double checking I see “Use As Separate Displays” in the Screen Mirroring menu is what we need and generally I toggle this without thinking about it. “Displays have seperate Spaces” in the System Settings should be off. Apple love messing with the System Settings! :-/

1 Like

Are you still having this issue? Or did you solve it by turning off in the System settings?

Yes, solved by turning off in the System settings. Curious tho because it feels like its now duplicated and this causes confusion. Haven’t replicated this on other machines with the same OS version yet but will test.

Good to know if anyone else bumps into this issue running newer versions of OSX.