Audio not sync to videofile

audio
video-capture
#1

So I’m triggering movie clips that include audio. but when i change the in and out points the movie is responding but the audio always starts at the beginning of the file. Am I overlooking something? i don’t get it to be synct. I use the HAP codec.

thanks!

0 Likes

#2

Could you give us some more specs about your system, version of VDMX?

0 Likes

#3

yes! Version b0.8.7.2.4

I run a macbook pro mid 2015
OS 10.15.7
2.2 ghz quad core intel i7
intel iris pro 1536 mb

0 Likes

#4

What did you use to encode those HAP files?

0 Likes

#5

I used the AVF Batch exporter to export .mp4 files to Hap or Hap alpha (tried both) the exporter turns them into .mov files.

0 Likes

#6

Yes, HAP is an MOV codec. Can you take a screen shot of your settings? Also, do you have access to Adobe Premiere or any other encoders?

0 Likes

#7

Yes i’ve acces to premiere but also media encoder

0 Likes

#8

VJ Media Encoder Presets.zip (28.4 KB)

Try one of these adobe media encoder presets. I believe the reason your audio is restarting is because of the codec that it is encoded in before you “pass thru” it to your newly encoded video file. For conversions such as Web MP4s (such as youtube, vimeo, etc.) you’ll want to make sure to re-encode the audio and video, streaming codec protocols are designed to reduce bandwidth, not for quick scrubbing and looping.

Let me know if one of those Media Encoder presets works for you. There are there in that zip, an 1080p MP4, and two different HAP settings. All of which, I’ve had success with in the past.

0 Likes

#9

THanks a lot, Tried all 3 of them but still something seems off. Also the HAP codec does not seem to be working. Im pretty sure the audio playback issues are a codec problem by now. Can’t seem to find the right codec anywhere…

0 Likes

#10

Do you think i should go for the new beta software of vdmx, to try if that works?

0 Likes

#11

When you installed VDMX, did you install the HAP codecs? If not, you can get them here:
https://github.com/Vidvox/hap-qt-codec/releases/download/version-12/HapQuickTimeCodec.Mac.v12.pkg

You should be able to select HAP in the Video Codec drop down for Media Encoder, if not, then the HAP codec may not be installed correctly on your system.

0 Likes

#12

Any chance you could share some of those clips that you were having an issue with? So we could test on our end?

Thanks!

0 Likes

#13

Try playing it back in VLC Andy see ignorance the audio is OK. Also check your source file.

It sounds more like it’s an issue with either your video system or audio system .

So video matrix / processing systems may induce a delay in your video.

More so check the latency on your audio card/system . Many audio installation systems in venues run thru processors and those will always introduce delays

0 Likes