Audio not in perfect sync

#1

Hi, I am trying to play three videoclips that also include audio at the same time and the audio is not perfectly in sync. I use a boolean triggered by cue list to start a random video from my media pool on each layer.
I tried converting the videos to hap already did not help either.

0 Likes

#2

A few Q’s:

Can you get a screen recording of what you are experiencing?

Do all the videos have the same audio frequency? Hz. 48000 Hz or 44100 Hz?

Do the videos themselves sync up in an editing timeline?

Are you preloading the media?

How fast is the disk you are playing them back on? (You can find this out with BlackMagic Disk Speed Test).

0 Likes

#3

Can you get a screen recording of what you are experiencing?

i can also send my project files and the videos if needed but here is a recording, i mute one layer and you can see they are a bit offset: https://youtu.be/RnAuqGUyFzM
here i am trying to start the videos on beat but the same problem is happening when using immediatly

Do all the videos have the same audio frequency? Hz. 48000 Hz or 44100 Hz?

yes they all 48000 and my output is set to that too

Do the videos themselves sync up in an editing timeline?

in ableton i can play three of them in perfect sync, as you can see in the video i have the same file on layer 1 and 3 and they are not in sync

Are you preloading the media?

i do now

How fast is the disk you are playing them back on? (You can find this out with BlackMagic Disk Speed Test).

macbook air m1 internal ssd, videos have a bitrate of about 49126 kb/s so should be fine

0 Likes

#4

Sure, do you want to share the project and video files? (If you want to keep it private you can send them to support at VIDVOX . Net.)

0 Likes

#5

sent an email, just in case someone needs the file (without the videos, just place some in the media bins on both pages) it is here: DJ_E_drive.vdmx5.zip (36.8 KB)

1 Like

#6

Great, Thanks for that!

Looks like you had your timelines were synced up to the clock. (The Red stopwatch icon). I believe this was the Quantized Playback button, but it essentially syncs your playback speed with the clock, so if you speed up the clock, you’ll speed up playback.

52%20AM

When I disabled this on all three of your layers, everything played back in sync.

Here’s the modified project to try for yourself:
DJ_E_driveProjectileObjects.vdmx5.zip (37.4 KB)

0 Likes

#7

thanks for the effort but sadly this still does not work for me, i switched that on in the hope of fixing my problems, here is a new video with the updated settings where the audio is out of sync while two layers play the same clip: https://youtu.be/XpdgSX5TFIM

0 Likes

#8

I wonder if it is the performance power of the M1 air? Do you have 8GB or 16GB of memory, and is VDMX b8.8.0.5 running natively or under Rosetta 2?

Thanks

0 Likes

#9

I have the macbook air with 16gb, I think playing three fullhd videos should be fine but I also read that it has some troubles with hap, so i tried on my other macbook (macbook pro 2014 with i5 and 8gb ram) and there i had the same syncing issues with the audio, what machine are you using where it runs fine?

I also checked and my vdmx says beta 8.8.0.5 universal app, open with rosetta is not ticked.

0 Likes

#10

I’m using an M1 Max with 32GB of memory.

Can you do another screen recording and keep the layer player controls windows open. Collapsing them means I can’t see how the timing is out of sync. Please arrange them like they were in the updated project (photo above). Thanks

0 Likes

#11

https://youtu.be/UXo0PnO0qGg in this recording the timings look good, sadly the audio is still not in sync, I think I will just use ffmpeg mosaic to combine all 125 possible combinations into 4k clips that will then play in sync, this way it will be stable for sure

0 Likes

#12

Here’s how it performs on my machine:

Do you have anything else running?

0 Likes